[hfs-user] Problems with MacBinaries

m.siennicki@cloos.pl m.siennicki@cloos.pl
Wed, 21 Aug 2002 00:27:50 +0200


Hi,
  First, I have to say that I'm Mac newbie --- I'm just playing
with an old 7300 for 2 days. For two days i'm trying to copy one
file (MacOS upgrade) into Mac's disk, and I cannot do it.
I downloaded the file into my PC, I attached Mac's disk into
mine PC SCSI bus and I try, and try, and try, ...
hmount works,
hdir, hcd works too, hcopy Mac disk -> e2fs works. But I cannot
copy any *.bin file into Mac disk.
When I try to copy files downloaded from apple.com, I see message:
hcopy: "THERE IS SOME .bin FILENAME": unknown, unsupported, or corrupt MacBinary file (Invalid argument)

When I try the other way, for example:
$ hcopy ":FreeHand 5.0.1" .
I get the .bin file, but, when I try to copy it back into hfs I get:
hcopy: "./FreeHand_5.0.1.bin": error seeking medium (Invalid argument)

These .bin files are recognized by ``macutils''. 

I think the problem is that the source doesn't compile properly
on my PC - linux-2.4.19, Athlon, gcc 2.96.

Can somebody help me? (I think the problem could be in me too :) )

Sincerely,
Marcin

(I tried to use kernel hfs driver, too: I tried this way:
1) I extracted file.bin with macunpack into file.data, file.rsrc, and file.info
2) I copied file.data into hfs directory as ``file''
3) I copied file.rsrc into .resources (or sth like this) directory as ``file''
It doesn't work too - I see my file as plain document :(
)