[hfs-user] Help needed...

Entwicklung entwicklung@whengenibk.de
Thu, 18 Apr 2002 15:27:23 +0200


This is a multi-part message in MIME format.

------=_NextPart_000_000B_01C1E6ED.89BFF1A0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Hello listers,
                   I've encountered a problem in my HFS directory =
structure which I have tried to elaborate below... please do take a look =
at it and see if some plausible reason strikes you.

I have a file File-X say under Root. Under Root I also have a folder =
Folder-X inside which I have another file of the same name i.e. File-X =
and another file File-Y.=20
File-X is a pdf file of size 42MB and File-Y is a simple text file only =
4kB in size.

All icons get correctly displayed from my CD so I presume all the leaf =
nodes of my catalog B-Tree are getting iterated through (since the icons =
get set based on the filetype and creator fields).

The problem I'm facing is that File-Y (within Folder-X) is readable, =
File-X under Root is readable but when I try to open File-X which is =
under Folder-X  Acrobat seems to go into sleep mode.=20

What could this possible be due to ? I first thought the references =
maintained to the file extents (or file size)
was wrong... but it seems to be right... the start block as well as the =
block count (in the leaf nodes) seem to be all right... what else could =
cause the icon to get displayed but not allow the file to be opened ?=20

- The file is correctly written (twice at two different locations) and =
readable the first time.
- The start-block and block count seems to be right for both.=20
- Another file written at the same level is readable.

Could it have something to do with the size of the file ? Please help if =
you have any idea what could be causing this..

Regards,
Nandini Hengen
=20

------=_NextPart_000_000B_01C1E6ED.89BFF1A0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content=3D"text/html; charset=3Diso-8859-1" =
http-equiv=3DContent-Type>
<META content=3D"MSHTML 5.00.2920.0" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Hello listers,</FONT></DIV>
<DIV><FONT face=3DArial=20
size=3D2>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;I've=20
encountered a problem in my HFS directory structure which I have tried =
to=20
elaborate below... please do take a look at it and see if some plausible =
reason=20
strikes&nbsp;you.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I have a file File-X say under =
Root.&nbsp;Under=20
Root I also have&nbsp;a folder Folder-X inside which I&nbsp;have another =
file of=20
the same name i.e. File-X and another file File-Y.&nbsp;</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>File-X is a pdf file of size 42MB =
and&nbsp;File-Y=20
is a simple text file only 4kB in size.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>All icons get correctly displayed from =
my CD so I=20
presume all the leaf nodes of my catalog B-Tree are getting iterated =
through=20
(since the icons get set based on the filetype and creator =
fields).</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>The problem I'm facing is that File-Y =
(within=20
Folder-X) is readable, File-X under Root is readable but when I try to =
open=20
File-X which is under Folder-X&nbsp;&nbsp;Acrobat seems to go into sleep =
mode.=20
</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>What could this possible be due to ? I =
first=20
thought the references maintained to the file extents (or file=20
size)</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>was wrong... but it seems to be =
right... the start=20
block as well as the block count (in the leaf nodes) seem to&nbsp;be all =

right... what else could cause the icon to get displayed but&nbsp;not =
allow the=20
file to be opened ?&nbsp;</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>- The file is correctly written (twice =
at two=20
different locations) and readable the first time.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>- The start-block and block count seems =
to be right=20
for both. </FONT></DIV>
<DIV><FONT face=3DArial size=3D2>- Another file written at the same =
level is=20
readable.</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Could it have something to do with the =
size of the=20
file ? Please help if you have any idea what&nbsp;could be causing=20
this..</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Regards,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Nandini Hengen</FONT></DIV>
<DIV>&nbsp;</DIV></BODY></HTML>

------=_NextPart_000_000B_01C1E6ED.89BFF1A0--