mounting Mac Syquest cartridge on Linux

Ambrose Li hfs-interest@ccs.neu.edu
Thu, 8 May 1997 18:10:02 GMT


Hello Holger & Andras,

I have just tried both hfs-fs and hfsutils, and they both failed
to read the Syquest. However, it looks more like it is the SCSI
code that is not recognizing the disk, not the two hfs packages.

I am not sure if I have done anything wrong (perhaps even obviously
wrong), since I am not very familiar with interfacing SCSI devices.
Perhaps you or someone can look at what I did and be able to tell
me if something I did is not right?

The software I used are:
Linux kernel	2.0.30
hfs-fs		0.95
hfsutils	1.17b

What I did to load the SCSI driver:

---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------
bash# insmod aha152x aha152x=0x340,11
aha152x: BIOS test: passed, detected 1 controller(s)
aha152x0: vital data: PORTBASE=0x340, IRQ=11, SCSI ID=7, reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended translation=disabled
aha152x: trying software interrupt, ok.
scsi1 : Adaptec 152x SCSI driver; $Revision: 1.18 $
scsi : 1 host.
  Vendor: SyQuest   Model: SQ5110C           Rev: 4AA0
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: hdwr sector= 512 bytes. Sectors= 173456 [84 MB] [0.1 GB]
sda: Write Protect is off
 sda:scsi1: MEDIUM ERROR on channel 0, id 0, lun 0, CDB: 0x03 00 00 00 10 00
extra data not valid Current error sd08:00: sns = 70  3
ASC=19 ASCQ= 0
Raw sense data:0x70 0x00 0x03 0x00 0x00 0x00 0x00 0x0a 0x40 0x00 0x00 0x00 0x19
0x00 0x00 0x00
scsidisk I/O error: dev 08:00, sector 0
 unable to read partition table
bash#
---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------

What I did to mount the Syquest using hfs-fs:

(I have set my /syquest in the fstab like Holger suggested.)

---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------
bash# mount /syquest/
scsi1: MEDIUM ERROR on channel 0, id 0, lun 0, CDB: 0x03 00 00 00 10 00
extra data not valid Current error sd08:00: sns = 70  3
ASC=19 ASCQ= 0
Raw sense data:0x70 0x00 0x03 0x00 0x00 0x00 0x00 0x0a 0xc0 0x00 0x00 0x00 0x19
0x00 0x00 0x00
scsidisk I/O error: dev 08:00, sector 0
hfs_fs: unable to read block 0x00000000 from dev 08:00
hfs_fs: Unable to read block 0.
mount: wrong fs type, bad option, bad superblock on /dev/sda,
       or too many mounted file systems
bash#
---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------

What I did to mount the Syquest using hfsutils:

---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------
bash# hmount /dev/sda
scsi1: MEDIUM ERROR on channel 0, id 0, lun 0, CDB: 0x03 00 00 00 10 00
extra data not valid Current error sd08:00: sns = 70  3
ASC=19 ASCQ= 2
Raw sense data:0x70 0x00 0x03 0x00 0x00 0x00 0x00 0x0a 0xc0 0x00 0x00 0x00 0x19
0x02 0x00 0x00
scsidisk I/O error: dev 08:00, sector 0
hmount: /dev/sda: error reading from device (I/O error)
bash#
---------- 8< ---------- cut here ---------- 8< ---------- cut here ----------

The disk itself is fine, as a real Macintosh can read it.

--
Ambrose Li. acli@mingpaoxpress.com. Ming Pao Newspapers (Canada) Ltd.,
EDP department.  1355 Huntingwood Drive, Scarborough, Ontario, M1S 3J1
Canada.  Voice +1 416 321 0088  Fax +1 416 321 9663.